RSW starten nicht im Adminkontext unter Windows Vista

Hier können Sie über Probleme mit dem Programm berichten

RSW starten nicht im Adminkontext unter Windows Vista

Beitragvon WinFAQ » 16.06.2008, 11:21

Fehler:
BS: Vista Home Premium, SP1
Während beim Desktop RSW völlig problemlos startet kommt beim Notebook zunächst wie auch beim Desktop der Hinweis "Ein nicht identifiziertes Programm möchte auf den Computer zugreifen".
Klicke ich nun auf Zulassen verschwindet das Fenster die Eieruhr kommt ganz kurz (es wird kurz auf die Festplatte zugegriffen) und das war es dann auch.
Von RSW nicht zu sehen.
Schalte beim Start von RSW die Administratorrechte ab erhalte ich den Hinweis das ich das Programm als Administrator starten soll mit dem Hinweis wie das geht. Klicke auf OK startet RSW vollständig. Nur das hilft wenig, da ich ja Administratorrechte benötige.

Eingebaute Fehlermeldung (erst ab Version 1.8.4):
Fehlernummer: 339
Fehlertext: Die Komponente COMDLG32.OCX oder eine Ihrer Abhängigkeiten ist nicht richtig registriert: Eine Datei fehlt oder ist ungültig.

Lösung:
Habe mich im Internet bezĂĽglich COMDLG32.OCX umgesehen und einiges darĂĽber gefunden. Scheint ja seit Bestehen von Windows ein Problem zu sein. Diese von mir berichtete Fehlermeldung habe ich zurĂĽck bis W98 gefunden.

Unter Vista kann man offensichtlich die Datei mit Regsvr32 %SystemRoot%\System32\COMDLG32.OCX nicht!!! registrieren. Auch das deregistrieren mit Regsvr32 %SystemRoot%\System32\COMDLG32.OCX /u funktioniert so offensichtlich nicht.
Ich habe eine Information gefunden nachdem eine Registrierung nur mit "ausgeschalteter" Benutzerkontensteuerung möglich ist.

Nach ausschalten der Benutzerkontensteuerung habe ich ohne COMDLG32.OCX zu registrieren bzw. deregistieren RSW einfach gestartet. Und siehe da RSW lief. Auch das ändern der Registry funktionierte.
Nun habe ich die Benutzerkontensteuerung wieder aktiviert. RSW neu gestartet prompt kam wieder die Fehlermeldung COMDLG32.OCX ist nicht richtig registriert.

Nun habe ich wieder die Benutzerkontensteuerung ausgeschaltet. Dann habe ich zuerst die COMDLG32.OCX deregistriert Regsvr32 %SystemRoot%\System32\COMDLG32.OCX /u. Dann habe ich sie wieder registriert
Regsvr32 %SystemRoot%\System32\COMDLG32.OCX.
Dann habe ich wieder die Benutzerkontensteuerung eingeschaltet und den Rechner neu gestartet.
RSW startet nun ohne Probleme.

Danke an Herbert Temmel fĂĽr die Informationen und der Hilfe bei der Fehlersuche

GruĂź
Frank
Benutzeravatar
WinFAQ
Site Admin
 
Beiträge: 188
Registriert: 10.04.2007, 13:15
Wohnort: Hannover

ZurĂĽck zu Probleme





Hauptmenü

Forum

Partnerseiten